Snowmobile World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Howdy ---I have a 2003 Rmk 800 vertical escape, the detonation sensor seems to go off way more than it should.

I understand that it is a safety feature when the gas is bad, but I have also mixed race gas (3 gals of race gas to 7 gals of 91 octane) and I can still get it to go off.

It only goes off if I have it fully pinned for over 5 seconds. Most of my sledding is done between 10,000 ft - 12,000+ feet. Everything else with the sled seems perfect, plugs never foul, it always starts right up. It has been fully rebuilt, new cases, slp crank /bearing, new pistons.

Any ideas? Can I unhook it? replace it?

Thanks for your help
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
is the det light coming on?[/b]

Yes, the red temp light flashes and also the timing is retarded. I am told that if it flashes it is the detonation deal, and if it is sold then it is the temp, which seems to be the case as the temp light did come on and stay sold when I was towing a trailer on hardpack snow.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Yes, the red temp light flashes and also the timing is retarded. I am told that if it flashes it is the detonation deal, and if it is sold then it is the temp, which seems to be the case as the temp light did come on and stay sold when I was towing a trailer on hardpack snow.[/b]
Nice, I spelled SOLID wrong twice, sold was not the correct word.
 

·
Registered
Joined
·
2,032 Posts
i thaught the det light was seperate. all the xc8 sleds ive dealt with have a very touchy temp sensor. i take mine out and plug the hole. this isnot recommended for the average joe. you need to be careful if you do.
 
1 - 5 of 5 Posts
Top