Snowmobile World banner

1 - 11 of 11 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
alright sorry to do this to you guys cuz i know how the zr580 topic goes around here but yes i was stupid enough to buy one last year well long story short the motor blew twice last season and i dont want to run that motor next year. i was thinking about doing a motor swap...do you guys think it would be horrible to plant a zr 600 motor in it? how available are these motors and are they rediculously expensive? lemme know what you would do? thanks for your time...!!
 

·
Registered
Joined
·
2,646 Posts
Get rid of it fast!!!! Why waste all your time and money putting a motor in that outdated chassis? Used 600 will be cheap this season. I bet around 2500 to 3000us. They were 3k to 3500 last season around me. You'll get SOOOOO Much more sled for the money.
Caleb
 

·
Registered
Joined
·
3,679 Posts
I don't know. I know it might be out dated, but the 580 chassis was so pretty.
Plus there's something really cool about having a totally unique sled, and there can't be very many 600 motors i those old chassis's.
 

·
Registered
Joined
·
1,357 Posts
I would definetly just fix it and trade it.  I can't believe the difference in wait between that frame and the new style plus i'm guessing you have aws 4 front and don't have a fastrack tsl in the back.  I'll put bets 600s will go cheaper then even the 2500 if it don' snow right away.  I was looking at buying a 01zr800 this spring for around 3500 to 4000.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #6
i think the only one that sees where im coming from is newfie...i love the looks of that sled, i dont want somthing everyone has...Yes i do have fasttrack suspension. i want info on a motor swap...
 
A

·
Guest
Joined
·
0 Posts
Skifreak, I would get ahold of a dealer that really knows what they are talking about.  The front frames are different and the motor mounts are different.  You would have to check to see if you can swap the motor mounts.  I know what you're talking about on the looks of the sled, I have a 96 ZRT that I have been trying to put a ETT suspension in for a while but no one can tell me if it will definitely work.  Best of luck.
 

·
Registered
Joined
·
1,357 Posts
ARCTICCATZRT600  look in the other subject I started about putting a fastrack tsl under a 95ext.  My local dealer has done quite a few I found out.  I can get you his number or find out what if anything needs to be changed for you.  I think were going to go ahead and do the swap on my friends sled to so I will need to get the info anyway.
 

·
Registered
Joined
·
315 Posts
I know exactly where he is coming from on this. I had a 94 ZR 700 that I loved. I did finally end up selling it. I bought the 2002 ZR 600 EFI. I am sorry to say that that 700 would put my new 600 to shame. Even though the motor mounts are different you can fabricate new mounts. you'll want to use a good solid material and make sure everything is lined up, especially the spacing of the clutches. Black magic made a kit to use a bigger motor in the sno pro chassis. They may have some insite on what to do. I will say this the ride quality of the newer chassis is far superior to the older sled. Good luck which ever direction you go in.
 

·
Registered
Joined
·
315 Posts
I forgot to mention that if it is too much of a hassel to change it over... Black magic has a 625cc big bore for that engine. I don't know what you are looking at for cost of dropping the newer motor in that chassis, but the big bore kit is $1100. Also the 580 motor had a problem breaking rings if i remember correctly something to do with where the ports were in the cylinder. I am sure the big bore kit has a better design than that. You may also want to replace the seals in the crank case if they go bad they will blow the motor aswell. If you can't find a newer 600 motor to drop in you may be able to find a 700, just be sure to get the reinforcement plate that goes on the clutch side of the motor. I was just thinking that the motor mounts on the 580 might be able to be used on the 600 if the holes are in the same places. Hope this helps
.
 

·
Registered
Joined
·
138 Posts
Ok, I have a question about the 580 motor. I had a 2000 ZL 580 EFI ESR. It blew up 3 time within 300 miles. The PTO side kept going lean at about 60 mph. AC told dealer to replace oil pump each time. Dealer thought it was the ECU. Anyone on here seen this problem and know what it actually was. I got rid of the sled a year ago, after the last rebuild. It is about 500 miles from me now!!!
 
1 - 11 of 11 Posts
Top