Snowmobile World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,068 Posts
Discussion Starter #1
Lost everything on my computer this weekend!!!! :crazy: I had a link to a website dedicated to the Fusion 900 owners anyone know of this site? :blush:
 

·
Registered
Joined
·
1 Posts
Lost everything on my computer this weekend!!!! :crazy: I had a link to a website dedicated to the Fusion 900 owners anyone know of this site? :blush:[/b]
Anyone please!!

Bought a fusion -05 last spring and drove it for only one day.. before the snow was gone :( .

My best friend has one stock fusion -05 too and he outrun me... :cussing:
The primary spring in mine was white and started to pull at 4000 rpm but the max rpm was at 7200-7300- His was at 7800 rpm.
Thinking of getting a orig spring OR a clutch kit. The EPI kit was "made to eliminate belt slippage" and beside that it didnt seem to improve the performance so much.

Help me outrun my dear friend! :)
(Dont use the trail if I dont have too..powder if possible. Top speed is not what I´m looking for)
 

·
Registered
Joined
·
114 Posts
The 05 fusion max rpm should be around 7400-7500. Don't go by the recall on the display because it doesn't take into account for track slippage. So his sled could have been reaching 7800 while spinning if not he is over revving.

I think the stock spring is blue/white but don't quote me.

Most people who bought the epi kit was disappointed with performance. Some have used a White Lake polaris kit and seem to like it. Also there are big discussions about the TEAM 719 helix that many of us are running that helps top end. There are two angles on this helix. Typically stock sleds are using the smaller and angle and the bigger angle for mod sleds.

I never had belt blowing issues with my sled and many don't once the updates have been completed.

Anyone please!!

Bought a fusion -05 last spring and drove it for only one day.. before the snow was gone :( .

My best friend has one stock fusion -05 too and he outrun me... :cussing:
The primary spring in mine was white and started to pull at 4000 rpm but the max rpm was at 7200-7300- His was at 7800 rpm.
Thinking of getting a orig spring OR a clutch kit. The EPI kit was "made to eliminate belt slippage" and beside that it didnt seem to improve the performance so much.

Help me outrun my dear friend! :)
(Dont use the trail if I dont have too..powder if possible. Top speed is not what I´m looking for)[/b]
 
1 - 6 of 6 Posts
Top