Snowmobile World banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a stock 98 xc700 just put on a boost bottle, I cant seem to get the set up right w/ the carbs, has low end bog,also when cold sled it sound like its drowning,I need help.
Has anyone had similar problems?
 

·
Registered
Joined
·
282 Posts
I used to have the same sled and I put a Hot Seat boost bottle on it. I am trying to remember what I had to do to it when I installed the bottle and I know that I had to adkust the air screw out. What bran noost bottle did you get? I would try to call the shop that made it. Mine was a Hot Seat bottle and came with a instruction sheet with everything I needed to know about install and set up. Might try giving them a call and see if they can e-mail or fax a set up sheet to you. Mine had the same bog off idle but the boost bottle really cleaned it up. I also put a 45/36 helix and dropped a tooth on the top sprocket. Sled screamed out of the hole and still would run the fastest among the group I ride with. Sold it and ride a Pro-X 440 now. The 440 is faster 0-60 but doesn't have the same top end and arm pulling torque but is a lot more fun in the twisties and washboards.
 

·
Registered
Joined
·
193 Posts
Can you get it to idle right?  If not, will giving it a little choke while idle help correct the troubles?  If so, I would say it could be a little lean in which case you will have to adjust the air screw (in?), or if that doesn't work increase your pilot jet size.

The way I understand it, a boost bootle will lean out your low end, maybe you're too lean.  Of course it doesn't make sense to use a boost bottle to lean it out, then have to use bigger pilots to richen it back up.
 
1 - 3 of 3 Posts
Top