Snowmobile World banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Just bought the slad last week, and when i start moving the machine boggs right out, almost shuts off, any ideas?
 

·
Registered
Joined
·
267 Posts
are you giving it a lot of gas or just a little?
 

·
Registered
Joined
·
9 Posts
So it will idle fine but bogg when you hit the throttle? I'd say empty tank and put fresh gas in it. Warm up the engine too. U could try new spark plugs. Look at the spark plugs, they should be tan in color inside cylinder.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I drained the tank when i got it, got new plugs and wires on it. The machine will idle fine, but son as i give it gas it boggs, wether its alot of a little of gas, even if i have been riding for an hour. I also had the carbs off and cleaned them yesterday.


So it will idle fine but bogg when you hit the throttle? I'd say empty tank and put fresh gas in it. Warm up the engine too. U could try new spark plugs. Look at the spark plugs, they should be tan in color inside cylinder.[/b]
 

·
Registered
Joined
·
267 Posts
Do you know how it is jetted? Are you riding in warm temperatures?
 

·
Registered
Joined
·
9 Posts
OK sounds like u can do some work :) It is an old engine, maybe check compression? Really sounds like a mixture thing though.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Checked the compression today about 115-120 in each cylinder. She seems to flood herself if left idling, and at about 6-65 hundred RPM.

OK sounds like u can do some work :) It is an old engine, maybe check compression? Really sounds like a mixture thing though.[/b]
 

·
Registered
Joined
·
9 Posts
Hmmm... Maybe a mouse made a nest in the exhaust. The choke could be stuck open a little. But, my machine runs best in 20 degree weather.
 

·
Registered
Joined
·
59 Posts
drain the crankcase, no gas should be in there
 
1 - 10 of 10 Posts
Top