Snowmobile World banner

1 - 7 of 7 Posts

·
Registered
Joined
·
190 Posts
Discussion Starter #1
Hey Guys,

My Mach has been acting up a little all of this year.  It seems like when I hit a bump, or take a pretty sharp corner it just cuts out.  If I'm flying down a field and I hit a bump it will just cut out for a split second, but when it cuts out around the sharp corners it cuts out worse.  Both are very annoying.

I finally got it in the shop and my mechanic said that he thinks that it may be the kill switch shorting out so he ordered me a new one.  Anybody else ever had this happen?

He said that if it turns out that it isn't the kill switch he will take it back off and not charge me for it.  He also said that today he is going to pull my pipes off and see if he can find any bare wires or anything like that.

Just was wondering if anybody else had seen a kill switch fail before.

Thanks for the help.

-Josh
 

·
Registered
Joined
·
221 Posts
Never had kill switch problems but I have had the ignition switch plug in come loose giving me grief all winter 'till I found the plug was loose, causing the engine to shut down or stutter on rough trails. Also have a look at your tether plug.
 

·
Registered
Joined
·
190 Posts
Discussion Starter #5
Thanks Guys.

Paul, I haven't tested it because I have been near the sled since 2 weeks ago.  I keep it at my Parents place which is quite a hike from my house.  I just got it in to the mechanic on Wednesday (my dad brought it up for me), and he looked at it yesterday with his diagnosis.  Just out of curiousity though, is it easy to bi-pass the kill switch and test it that way?  I wonder why he didn't try it.

bobber, the plug in the back of the switch was loose, or somewhere else?  The guy also suggested it may be the tether but obviously wasn't too sure.  I am not sure why he decided to try the switch first (must be because it was the cheapest).  

That's a good idea though, maybe I will call him and have him check the connections for the ingition switch. Thanks a lot for the help!

-Josh
 

·
Registered
Joined
·
190 Posts
Discussion Starter #7
Thanks again guys.

Well, it wasn't the kill switch.  While he was waiting for it to come in he checked under the motor and saw some wires down there that looks like they may be split.  He said that they run close to the steering linkage so that may be why it does it around sharp corners.  It also does it over bumps so that would make sense.

He checked all of the wires on the ignition switch and they were good, so that is all he can come up with.

Unfortunatly he said that he doesn't think that he can get to them by just pulling the pipes.  He said that he thinks that he needs to pull the motor to repair them.  Man, what a treat.

Oh well, just thought I'd give you guys an update.  Thanks for the help.

-Josh
 
1 - 7 of 7 Posts
Top