Snowmobile World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
Hey guys!

i got to ride the 670 finally. I noticed that it won't idle for more than a few seconds before it dies out and needs a squirt to refire. i checked the air bleed (pilot) screws to see where there were and it was set @ 1.25 turns out. So i figured ok... thats pretty far in already.

So then I took a look at the oil cable adjustment. am I right to assume the line on the case and the peen mark on the arm are supposed to line up with no throttle? If so then it's really close.

So.... i'm a bit stuck. I'm scared I might do the wrong thing and burn it up. I'm used to tuning my banshee. The 670 is all new to me so I'm not savy on her sound yet. If you guys could give me some insite....

Maybe the carbs need a cleaning? The pilot IS the smallest hole in those carbs, maybe it's a bit gummed...?...?

What else should I be checking or doing?

PS... I bought a goodwin clutch kit with secondary clutch that has the parts already in it for $250 shipped! I hope it makes a good difference. The secondary he sent me is in WAY better shape than my old rotten one. w00t SWRules :christmas:
 

·
Registered
Joined
·
97 Posts
Discussion Starter #2
anybody want to take stab at this one?

I was told that rotary valve motors don't idle anyways, and that my situation was normal... doubtful!

I've ridden other 670's that would idle fine and not be a slug under 2k. It seems like it's running out of fuel, because I have to squirt it to refire. But on the other hand it doesn't backfire like it's lean. Even if I give it generous amounts of thottle while it's bogging out it still will not come back up. It doesn't matter if it's cold or not, still the same thing.

Should I just set the idle for around 2k and forget about it?

It seems to run awesome over 2k and the pilot jet seems to be right on... nice and snappy

Need alittle insite!!!! Thanx boyz
 

·
Registered
Joined
·
2,782 Posts
Sure, I'll take a stab...$2.00

Pilot jets should be #60 and idle screw 2.25 turns out +/- 1/16 turn. Float level needs to be 18.1 mm (from bowl gasket flange). What RPM is it launching at?
 

·
Registered
Joined
·
97 Posts
Discussion Starter #4
$2.00.... man your cheap! hehe... I'd pay that anyday for some of your advise buddy!!!


Ok so I clearly have a gummed jet then eh... the screws are set at 1.25 turns out and it's still starving....yeah I have a better angle now

I haven't opened them yet so I can't give you a #

I think engagement is around 4600...??? :huh: And it's going straight to 8k when I slam it. I'm assuming the tach is reading a bit high. But I have the new kit to put in there so.... I just need a few minutes of free time.

I think this sled has the 40's on it not the 44's...

carbs are sync'd nicely...

Hope this helps!


Where do you measure the float level from?
 

·
Registered
Joined
·
97 Posts
Discussion Starter #5
BTW good call on those bolts!!! I had 3 of the long ones on the rotary side (rear) maybe this is why the gasket blew eh? plus the old one was a 4 hole... I bought an 8 hole this morning, maybe this will give a better sqeeze...?...
 
1 - 5 of 5 Posts
Top