Snowmobile World banner

1 - 7 of 7 Posts

·
Registered
Joined
·
310 Posts
Discussion Starter #1
On my secondary clutch, I put the goodwin spring and helix in, and now the secondary clutch bolt and washer dont fit. The bolt isnt long enough. What is the problem??
 

·
Registered
Joined
·
4,316 Posts
Make sure you pushed the clutch on all the way. It WILL fit.
 

·
Registered
Joined
·
1,674 Posts
The helix bottoms against the retainer,and it only goes together one way.I've never seen anyone have more headaches than you sledcrazy.Just go over what you have done as it must be something simple :D
 

·
Registered
Joined
·
310 Posts
Discussion Starter #4
Ive got nothing but headaches w/ that thing.
 

·
Registered
Joined
·
2,885 Posts
Crazy. Flimp the moving half of the clutch over,and you will see the gold colored washer under the spring is probably off center. ust bump it around till it is centered int he hole, and it should go on all the way.
 

·
Registered
Joined
·
118 Posts
It almost sounds like you don't have the clutch pushed on far enough. Is the shaft that goes through the helix flush against the spacer on the jackshaft and is the spacer pushed up to the jackshaft bearing? If it isn't, you don't have the spline of the clutch lined up with the spline on the jackshaft. I can't imagine why it wouldn't fit.
 

·
Registered
Joined
·
310 Posts
Discussion Starter #7
Thanks for the replies, I checked everything over, but I think im just gonna take it to the dealer this week some time, and have them get it on there.
 
1 - 7 of 7 Posts
Top