Snowmobile World banner

1 - 3 of 3 Posts

·
Registered
Joined
·
442 Posts
Discussion Starter #1
I found out what was wrong with my brakes not releasing..it was the plunger that the brake handle pushes in...the rubber held moister which in turn rusted the plunger and spring and now that I have the inside peice under the plunger working fine..I need a new plunger,spring,and rubber to hold it in place.I looked on ski-doo microfiche and it shows the rubber and plunger but no part number or arrow going to it!
so...now what,is there a rebuild kit I can get or something..?
THANKS
 

·
Registered
Joined
·
2,782 Posts
Rick,

No rebuild kit available (liability chickens) can you clean up the piston and spring and lube it with dielectric grease(compatable with brake fluid). Brembo used to offer kit for the 440 racer and motorcycle master cylinders..worth some investigation.
 

·
Registered
Joined
·
442 Posts
Discussion Starter #3
well what happened is I pulled the plunger (rod with spring) not knowing the spring was attached :crazy: :unsure: :whatever: :whistling: so anyway.... the rubber that held it in place and kept it all "protected " ripped in pieces! so I have nothing to hold the spring from falling out when its sitting back its hole... where it pushes on the inside plunger to make is work.
so if the rod with the spring would stay in place Id be all set for now until my other ebay one comes. THANKS for the reply :thumbsup:

BUT at least I found out why my brake caliper was sticking to my rotor! :tongue:
now that I had already bought another one off ebay a while ago.. thinking it was leaking and sticking,and come to find out the seal to the bearing on the chaincase was gone and gear oil is what was leaking all over the damn place lol :cussing: :hallo1:
 
1 - 3 of 3 Posts
Top