Snowmobile World banner
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
So I have a 92' Arctic Cat EXT550 El Tigre and it is spitting tons of gas out the carburetors, not sure why. It also does not have enough power to move out of the garage and it idles weird. New fuel line as well as spark plugs. I hooked up a predator 212 gas tank directly to the fuel pump and it runs fine, but when I hook it back into the original gas tank it does not have any power. Thank you all for your time and if anybody happens to know what is going on, please let me know.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
how long has the sled been stored. could be rotten old fuel, or the pick up tube in the tank is rotted off or plugged up
Not sure how long it has been stored, but the seller said that he replaced the fuel not long before I bought it. I will take a look at the pickup tube and see if there is anything wrong with it. Thank you
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
It ran really well without the muffler and a different gas tank. I think it may have been that the muffler was clogged or something like that. The carburetors also stopped spitting gas. I will try using the original gas tank without the muffler on and see what it does. My guess is when I tried using the original gas tank it must have pushed debris into the main engine causing it to bog down. Thank you for the help.
 

·
Registered
Joined
·
159 Posts
seen that issue with mufflers before not very common , they do plug up , sometimes due to oil carbon build ups some time you can burn it out with a torch , if it rattles when u shake it baffles broke loose
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #10 ·
It runs really well now without the muffler attached, I do have it hooked up to the original gas tank with some fresh gas. It is bogging still, but not as bad as before. It will still go up to 30 with no problem. Thank you so much!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
It's fixed! One of the carburetors was screwed up, a few loose parts and also the cable that controls the choke was eroded into the carb and was stuck on full without knowing. Thank you so much for your help!
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top