Snowmobile World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
HI, A LITTLE HISTORY FIRST. SAT FOR A FEW YEARS (4), 2000MI ON IT, NEW AIR BOOTS, CARB CLEAN FROM DEALER, NEW JETS. CARBS ARE INSINC

MY COUGAR RUNS GREAT! WITH THE EXCEPTION OF OF ONE THING.

1. IF I AM GOING SLOW IT SEEMS LIKE I HAVE LITTLE OR NOW POWER IN THE LOW END UNTILL I GET TO A STRECH TO OPEN IT UP CLEAN OUT THE CARBS AND ITS FINE FOR A WHILE TILL I END UP SLOW RIDING AGAIN. (LOTS OF EXAUST AND MORE SO IF I HAVE A PASSENGER.) NO GET UP AND GO WHEN ITS LIKE THAT.

OH YA I BURN CRAZY FUEL TOO.
JETS SET 1 1/2 OUT

ANY IDEAS, TO RICH? AND HOW MUCH IS TO LEAN?
 

·
oldslowsledder
Joined
·
6,491 Posts
What condition are the clutches and belt in? They act as your transmission and if not in good shape can make it feel sluggish as well.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
What condition are the clutches and belt in? They act as your transmission and if not in good shape can make it feel sluggish as well.[/b]

I will have a look, this has been going on since I bought the sled.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
OK, I have read up on belts and deflecting. Alot of it sounds like my problem.

I am getting mixed readings on how to go about the adding or removal of the shims, if needed. Can somone plz explaine this to me. Maybe a explanation of if the belt is sitting low in the sec. or a gap greater than 1.5in on deflective. How and what to adjust to fix.

My sled is at the cottage so bringing the proper parts could make or break the weekends.

Anything will help. Bringing in the sled is very expencive in this town.
 
1 - 4 of 4 Posts
Top