Snowmobile World banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
hey there i am having some issues with my 95 grand touring.When i bough the sled the drive bearings came out in pieces,I had to order all new bearings and stuff on the speedo side..
No when i drive i get a wierd wining nosie when in powder or while turning,the speedo also jumps on when the nosie starts and then goes away. It has all new speedo cable and insert aswell.

my main question is if any one noes how the speedo bearing should be put together,There is the backing plate a spacer and the bearing holder, Wich way do they go. it sounds like i have the spacer in the wrong spot and the drive shaft is moving side to side and help or pics would be great as this is the only thing that bugs me about this sled...




does the tunnel go between 11 and 4 or 4 and 12
 

·
Registered
Joined
·
83 Posts
The Chaincase bearing holds the shaft in position if I remember. The Speedo side is basically free flaoting on the shaft. If I remember, the bolt plate was thinner than the spacer. The bolt plate and spacer go together on the inside of the tunnel, and the speedo drive mount on the outside)engine bay) That way, the tunnel is sandwiched between thick brackets for striength. SO, Tunnel between 4 and 12
Is it a loud thumping noise you'r hearing? Check to make sure you got enough track tension. It could be the drive slipping on the drive lugs due to loose track.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
#### i have the spacer on the inside of the tunnel with the bearing holder :confused: ,That is wy it is moving back and forth i think,#### that is alot of work to fix,It was hard to put back together after taking it apart and it looks like this






I hope the plate goes on the inside so it fixes the problem.The sound is coming from the bearing area for sure,the track is a little lose but i can live with that....
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
So i just spent the night taking it apart and putting the spacer on the outside of the tunnel were the track is and the chain case wont line up at all,I had it right the first time so i just wasted 5 hours for nothing..damn. :confused: ...whats that nosie?
 

·
journeyman sled/motorhead
Joined
·
4,440 Posts
speedo cable bad?
 

·
Registered
Joined
·
5 Posts
Brand new cable and insert,it sounds like a high pich squeel,oh well drive here till she blows...[/b]
that does not look like the right bearing to me. the one in my old mach had a longer race that stuck out of the drive side. also the outer bearing housing was not flat across the outer edge. that bearing looks like ot belongs on the chain case side. i will look around and see if i still have the old one and try to post it for you.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
is the right bearing,the one in the pics is the stock one out of the chain case that came in it new.there was no bearing in the speedo side at all when i got it..

the new one looks the same too
 
1 - 9 of 9 Posts
Top