Snowmobile World banner

1 - 11 of 11 Posts

·
Registered
Joined
·
316 Posts
Discussion Starter #1
:doh: :cussing: :cussing: i was out riding today and stoped because i broke my choke levar. well i accidently unscrewed the throtte top off of the carb. and it came out now when i screw it back down and start it it runs at high idle and when i give it gas it takes off and does not slow back down please help we have 9 in and i am dyeing to get back out there.................. :withstupid:
 

·
Registered
Joined
·
3,008 Posts
No such thing as a dumb question, happy to help.
I assume your working on a roundside carb, the slide itself has an alignment notch in it the will match up with the carb it sounds like you don't have it aligned up properly and the slide is hung up. Take it back out and have a look and it'll all make sense.
 

·
Registered
Joined
·
316 Posts
Discussion Starter #4
there are mikuna carbs i took it back out and it does have a notch in one side half way and the other it goes all the way it is lined up when i put it back in . it idles fine now but when i give it the gas it takes off and runs away the throtle does not spring back and even if i puul it back manully it still runs off. about put it thru the living room .... ouch that would have got me in good with the wife today..
 

·
Registered
Joined
·
38 Posts
Originally posted by got snow??@Dec 1 2002, 01:12 PM
there are mikuna carbs i took it back out and it does have a notch in one side half way and the other it goes all the way it is lined up when i put it back in . it idles fine now but when i give it the gas it takes off and runs away the throtle does not spring back and even if i puul it back manully it still runs off. about put it thru the living room .... ouch that would have got me in good with the wife today..
have you got the return spring on top of the slide????? we hope???? :0:

steve in mass
 

·
Registered
Joined
·
3,008 Posts
Sure what it sounds like. If the spring is not missing, take the air box off and (with the engine OFF) work the throttle and see if the slides are returning properly. You didn't try and force the slide in and bend the needle did you?
 

·
Registered
Joined
·
316 Posts
Discussion Starter #7
yea the large sping in between the cap and the slide is in there and i pull the throtle to take up the slack before i screw it on but it still does it. i am going to spend a fortune if i take it to the dealer plus it will take forever because we have snow now.
 

·
Registered
Joined
·
316 Posts
Discussion Starter #8
sorry guys but when it comes to carbs or internal engine i am stupid. i know squat. how can you make sure that the needle is getting back down in the hole?
 

·
Registered
Joined
·
316 Posts
Discussion Starter #11
thanks for the help. hopefully the dealer can fix the clutch poblem easily. and cheap. i think i am going to try to figure out the shut off with this one thanks everyone...
 
1 - 11 of 11 Posts
Top