Snowmobile World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4,316 Posts
Discussion Starter #1
A buddy of mine is having alot of trouble with the shaft (bottom) holding the front arm shock on the skid bending and breaking the bolts off. This has happened three times already this winter. Is there a fix? Anyone else had this problem? There is a T-Cat in the area that is having the same problem as well.
 
 

·
Registered
Joined
·
533 Posts
Looking at my 2001 ZR and comparing it to a 1998 PS, the lower axle that support the front arm shock is different. On my ZR there is additional support.  Maybe this was done to prevent the axle from bending.

You may want to look at getting the newer style.  Take a look at http://www.brownsleisureworld.com/ and compare the sled in question against a newer model.  You may find a solution.

just my two cents!

newf
 

·
Registered
Joined
·
4,316 Posts
Discussion Starter #5
Thanks newf...but the schemes for the newer sleds aren't on there.

This is happening lots...somebody somewhere must have seen it
 

·
Registered
Joined
·
5 Posts
Happened to mine last year. 98 zr 6 shaft was bent and one of the bolts broke off inside it. Had the shaft straightened, broken bolt removed and re-threaded. Replaced grade 5 bolts with grade 8 and they seem fine for now. Someone at another site told me to go to dealer and buy the newer style shaft (hollow shaft with a bolt that goes all the way through both rails, like the one futher back that holds the tensioning springs on) but I plan on selling the sled and said screw-it!
Good luck!
 
1 - 6 of 6 Posts
Top