Snowmobile World banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Need some guidance here. I have a 2005 600 Edge Touring that has about 750 mies on it. When started and idling, it smokes like crazy - enough to fill up a garage full of smoke in moments. It also is spitting a bit of oil out of the exhaust. Only after I have ridden it for awhile does it stop. I've had it checked out by the dealer twice, and the last time they adjusted the oil pump, but it hasn't helped. Could I have a faulty oil pump? Any assistance would be much appreciated.
 

·
Registered
Joined
·
476 Posts
More than likely, you have no problem at all, as this is normal for most / all big 2 stroke engines. Two stroke engines always have an amout of gas and oil in the crankcase, and when you turn the engine off, it's still down there. Since most sleds sit around for weeks (except for you Alaska guys who ride every day) and over the summer, months at a time, start-up produces that blue cloud until it burn off. Once the engine is completely warmed up, like a ride for 10 miles or so, you should have no more big clouds of blue. Now, if after riding 2 hours and starting the sled after a quick trail stop produces plumes of blue, then maybe you are too rich or the pump is set too high. I don't know about you, but I'm ready for one of those 2 hour rides right now. :thumbsup:
 

·
Premium Member
Joined
·
935 Posts
More than likely, you have no problem at all, as this is normal for most / all big 2 stroke engines. Two stroke engines always have an amout of gas and oil in the crankcase, and when you turn the engine off, it's still down there. Since most sleds sit around for weeks (except for you Alaska guys who ride every day) and over the summer, months at a time, start-up produces that blue cloud until it burn off. Once the engine is completely warmed up, like a ride for 10 miles or so, you should have no more big clouds of blue. Now, if after riding 2 hours and starting the sled after a quick trail stop produces plumes of blue, then maybe you are too rich or the pump is set too high. I don't know about you, but I'm ready for one of those 2 hour rides right now. :thumbsup:[/b]


Yep....what SnoFast said!
 
1 - 3 of 3 Posts
Top