Snowmobile World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
If anyone could help sure would be apreciated. I have a 1990 formula plus with a 521, I am only getting fuel to 1 cylinder. lots of spark. checked and cleaned both carbs even switched them but still no fuel to the cylinder on left side of sled (when sitting on it). any ideas?
 

·
Registered
Joined
·
2,782 Posts
Do a compression test to verify if the rotary valve is rotating. You might also remove the carbs and look down the induction tubes with a flashlight to check if the rotary valve is turning. Does it fire when you prime it?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Do a compression test to verify if the rotary valve is rotating. You might also remove the carbs and look down the induction tubes with a flashlight to check if the rotary valve is turning. Does it fire when you prime it?[/b]
I took the rotary cover off it does rotate when i pull it over slowly. it will run on one cylender but the pto side wont fire at all.
 

·
Registered
Joined
·
2,782 Posts
I took the rotary cover off it does rotate when i pull it over slowly. it will run on one cylender but the pto side wont fire at all.[/b]
Take the clutch off and check the PTO crank seal
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
will try that tomorow. and let you know. thank you[/b]
Thanks for your help, I did a compresion test and pulled the top end off. Turned out there was a hole in the top of the piston the size of a dime. All fixed and running great..
 
1 - 6 of 6 Posts
Top