Snowmobile World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
428 Posts
Discussion Starter #1
Any body with a zr580 efi i need help! My gas milage is horrible i drove abot 7 or 8 miles today and i used a guarter tank of gas. The one thing is that the bolt that pushes on the back of the motor to help align the clutches was gone, but a guy i know helped rig up a piece to get by on but it still sucks gas. So what is the normal mpg for this sled i knew it wasn't the greatest  but not this bad.  
 

·
Registered
Joined
·
40 Posts
well that does stink!!
my old 99 zr 600 efi would get about 10.5/mpg with normal ridding.  it would only get about 9.5/mpg when squeezing the throtle across a hard packed lake!
 

·
Registered
Joined
·
884 Posts
I'd check for leaks.  Had the same problem with a 580 Carb. Sled, ended up that the water catch lines that run out the bottom of the Float Bowl had a crack in it and was leaking gas out of it.
 

·
Registered
Joined
·
11 Posts
I was worried about the mileage on my sled, until I refilled the tank.  Had about 57 miles on my ZR800, and the needle was bouncing just above the "E".  Pulled into the pump, and it only took 6.5 gallons.  Turns out the tank has a very big "E" zone.  'Bout 9 mpg on a brand new sled;  should get better once broken in and jetted properly.
 

·
Registered
Joined
·
12 Posts
Hilldweller: same thing on my 2001 ZR500APV.  Gauge read E and I put only 6.5 gallons to fill.  I assume your gauge is mounted next to but separate from the cap.  I wonder what the solution is ?  May have to post or call dealer.
 

·
Registered
Joined
·
13 Posts
Same thing here Hilldweller...I thought I was going to run out, based on the gauge...I pull up to the pump and put in 6 gallons?  Weird...Big E range is right...
 
1 - 8 of 8 Posts
Top