Snowmobile World banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3,910 Posts
Discussion Starter #1
We got enough snow to go out riding this morning. I fired up the REV and Mach and me and my buddys took turns driving them around.

One thing is for sure, My next sled will be another REV or somthing close to it. Its unreal. You dont feel bumps, doesnt lift inside ski, corners real hard, and is the most comfy sled you can ride.

One thing i noticed is that the wind protection is much better on the REV then on the Mach. That suprized me, but thats the case. So skidoo really did do there homework. Its also very quiet and smooth.

Powerwise its very quick. Ive driven a 600 Mxz on numerous occations and i think this would destroy it. It pretty much killed a well running formula 583 and it feels like a 800 mxz.

After driving this for about 10min I got on the Mach and drove it around. I was feeling bumps that I didnt know where there on the Rev, One thing I liked about the Mach was how you could kick out the rear end of the sled.

The power of the Mach was also night and day better then the REV. Wow after all summer of not driving a sled the Mach is a wake up call. MAN that 809 sucks you back. I would say just by estimate that if you lined up the rev and Mach in a 500 foot race the Mach would win by 5 or 6 sled lengths, It just has that much more power.

After riding both I thought about the pros and cons for both sleds. If skidoo wants to eliminate the cons all they got to do is put the 809 in the REV chassie.
 

·
Registered
Joined
·
70 Posts
where did you go sledding? i was up at my cottage and it was great up there. all my buddies brought up there new sleds one guy had a 600 REV another a F7 and the other had an RX-1 then there's me with my 92 EXT louder than all of them.
 

·
Registered
Joined
·
50 Posts
well im not the only one that wants a triple rev i see.

Raced a 02 800 mxz took him till about 100 km/h by quite a few lengths off the line, then he blew past. raced a cat 800 and we are even till about 100 then it slowly starts pulling on me. i was surprised, this 600 goes. anyone got any setup tips, gotta make it hook off the line, it just spins and wont even get all the weight off the skis, lengthed limiter and cranked up the middle shock, flipped up the transfer blocks too but still wont hook up. i guess its cause your so far forward.

but its one fast 600, thats all i got to say.
 

·
Registered
Joined
·
1,204 Posts
machzzzz1..a few weeks ago you were ticked off that the mags said the ck3 was a terrible chasis,so now do you agree?
 

·
Registered
Joined
·
3,910 Posts
Discussion Starter #6
Its got its disadvantages. :D But its still no buick Roadmaster.
 

·
Registered
Joined
·
1,204 Posts
:D lol,ok how about a station wagon?hope you enjoy the rev :D :thumbsup:
 

·
Registered
Joined
·
261 Posts
dusteater, theres got to be something wrong w/ your rev, we rode the proto last year and race it against my 02 800 that really runs and the 800 rev beat everyone off the line every time. and my new 600 i've put around 15 miles on it in 5" of fresh snow and it didn't hardly spin, it just picks up the ski's and goes. and i've made no suspesion changes. it sounds to me like your shock in frt. is stuck and doesn't let it transfer.or something to that effect.
 

·
Registered
Joined
·
978 Posts
My 800 rev with the out of the box settings just sat and spun, and all I did was flip the thick side of the block to the front and took the back stopper right off, you can also shave it down, but I read where they just took it off and ran a 1000 miles and didn't do any damage to the rail. Anyways that's all I did and it lifts the ski's just perfect and launches great, will be better with more snow. Right now it's more stud friendly conditions, but that's ending soon, getting lot's of snow in the next few day's :0: :0:
 

·
Registered
Joined
·
2,303 Posts
Try one of those 800 rev's. That would beat that mach z! Ya that new rev suspension is pretty sweet.
 

·
Registered
Joined
·
963 Posts
I tryed out my new 800 rev this weekend, I only have to say that It's the best first ride Ive ever done. Did about 30 K's and speeds around 160km/h easy. The only thing is that it has no pick up. The speedometer goes from 0 to 100 in a fraction of a second but youre going about 30. even with my 1.75 track, it still spines. I have to admit that the road was kind'a icy though. Can't wait to try it out on staight lines, lakes, bumps and jumps. I would like to point out something else, after the ride, we stoped for about 5 minutes and then started the sled again. After 5 secondes the sled went dead. I got it to restart after a couple of pull's and it ran OK for the rest of the day. The next day, I did a little ride, stoped the sled and started it up again. After 3 secondes it died and wont start anymore. There is no spark coming from the plug. This really sucks cause I thing I blew the electric box or someting. Anyways, I have to take it back to work (dealer) cause there is a recall for all the rev's with 1.75 " track. Ill keep you posted.

Here is a pic
 

·
Registered
Joined
·
524 Posts
I pulled the rear blocks and my rev hooks up fine, I was up in the air about studding but now tat Ive ridden it I wont stud it, the sled is planted to the ground fine the way it is.
 
1 - 13 of 13 Posts
Top