Snowmobile World banner

1 - 20 of 24 Posts

·
Registered
Joined
·
1,708 Posts
Discussion Starter #1
05 REV GTX The rear passenger hand warmers will not work. Was this way when I bought it. The wiring plugs into two wires. I have a good 12 volts there. After the two wires, it goes to another connection and then to the switch. The switch only has 3 wires to it, the hot and then the low and high wires I assume. At the switch, I only have 0.08-0.10 volts with touching the ground to the battery or the ground to another connection under the seat. It seems like I am not getting the 12 volts to the switch. Why would this be? Shouldnt the switch have 12 volts? Any help would be good. I hate electrical stuff!! :cussing:
 

·
Registered
Joined
·
1,708 Posts
Discussion Starter #2
At the connection after the first initial connection with just the two wires, there are several wires coming into and out, the wire to the switch, the wires from the switch to the warmers and so on. When I check the voltage here, the voltage reads ~ 12 volts but my meter is showing - negative. Not sure what this means but hopefully someone understands whats going on and can help me please. Thanks Greg
 

·
Registered
Joined
·
10 Posts
Wow,
I'm glad I'm not alone.........I have a 2006 GTX with 200 miles on it and the rear hand grip heaters have never worked. It's out of warrantee and so far two dealers are clueless as to what's wrong. Like yu, I'm getting no power to the switch. I'm about to pull up the driver seat, trace the wire to see where it goes and if there are any breaks. It's starting to snow and I want to get this fixed.

Should have stuck with Polaris

Good riding,
paul
 

·
journeyman sled/motorhead
Joined
·
4,440 Posts
Should have stuck with Polaris

Good riding,
paul[/b]
I know a fellow with an 01 edge 600 that would trade you for the gtx if it lc. XCR583 any pics of this wiring for me to see ? I am going to the dealer tomorrow to pick up some pants and will see if the gtx is still on the floor and check it out.
 

·
Registered
Joined
·
10 Posts
Thanks Doo for the offer but there is not much to see in a show room unless the driver and pass seats are removed. The problem is that all the wiring looks to be in in tact but still no power........
 

·
Registered
Joined
·
2,782 Posts
05 REV GTX The rear passenger hand warmers will not work. Was this way when I bought it. The wiring plugs into two wires. I have a good 12 volts there. After the two wires, it goes to another connection and then to the switch. The switch only has 3 wires to it, the hot and then the low and high wires I assume. At the switch, I only have 0.08-0.10 volts with touching the ground to the battery or the ground to another connection under the seat. It seems like I am not getting the 12 volts to the switch. Why would this be? Shouldnt the switch have 12 volts? Any help would be good. I hate electrical stuff!! :cussing:[/b]
Sorry I took so long in a reply XCR, There's a BRP campaign concerning just what you mentioned. Look at the attached document and see if you can get your dealer to belly up to the table on this issue.

[attachment=40941:pass_heater_camp.doc]
 

Attachments

·
Registered
Joined
·
10 Posts
TD,
Thanks very much. This make s things very interesting as I can't wait to show this to the 2 dealers that couldn't help me with this with this problem...

thanks again paul
 

·
Registered
Joined
·
1,708 Posts
Discussion Starter #8
Sorry, havent been on here past couple days, been a little under the weather. Thanks for the info DOC. Dooman, I will try and get some pics tomorrow. I hope to work on it some more tomorrow. Youve probably already been to the dealer but it may help to explain whats going on.
 

·
Registered
Joined
·
1,708 Posts
Discussion Starter #9
TD, I had talked to my dealer about this and he ran the VIN and said that there was nothing avaliable to do for it. He had said about there being a "RECALL" he called it but when running my VIN nothing avaliable. He gave me the print out and it showed the original owner and showed that there had been no warranty work on the sled. You seem to know the dealer stuff pretty good, is this somehting that I have to raise a fuss about to get them to do anything? The other thing is that they have a ton of sleds and quads sitting there to be fixed now and who knows when I would get it back.
 

·
journeyman sled/motorhead
Joined
·
4,440 Posts
TD, I had talked to my dealer about this and he ran the VIN and said that there was nothing avaliable to do for it. He had said about there being a "RECALL" he called it but when running my VIN nothing avaliable. He gave me the print out and it showed the original owner and showed that there had been no warranty work on the sled. You seem to know the dealer stuff pretty good, is this somehting that I have to raise a fuss about to get them to do anything? The other thing is that they have a ton of sleds and quads sitting there to be fixed now and who knows when I would get it back.[/b]
I mentioned a gtx passenger grip heat problem to dealer. he said " there is an update that it probably needs. I need the rear portion of the seat to do it."
 

·
Registered
Joined
·
10 Posts
That's easy.
Just pull the release strap that exits the back of the driver seat, disconnect the plug and take the seat to him...
 

·
Registered
Joined
·
2,782 Posts
Just an FYI gentlemen, This is a Campaign...not a service bulletin. It applies to 2005 models only, 2006 are supposed to be upgraded unless it's an early build. Read the Campaign with your dealer. It states ALL SERIAL NUMBERS and the termination date is 2008-10-03. If you call BRP customer support and say one of your children has suffered frost bite in their hands, they will take notice. BRP has had enough grief over the first generation Modular Helmets and frost bite.
 

·
journeyman sled/motorhead
Joined
·
4,440 Posts
I did say 05 to the dealer.
 

·
Registered
Joined
·
2,782 Posts
Wow,
I'm glad I'm not alone.........I have a 2006 GTX with 200 miles on it and the rear hand grip heaters have never worked. It's out of warrantee and so far two dealers are clueless as to what's wrong. Like yu, I'm getting no power to the switch. I'm about to pull up the driver seat, trace the wire to see where it goes and if there are any breaks. It's starting to snow and I want to get this fixed.

Should have stuck with Polaris

Good riding,
paul[/b]
This is what I was referring to Barry.
 

·
Registered
Joined
·
1,708 Posts
Discussion Starter #16
Just an FYI gentlemen, This is a Campaign...not a service bulletin. It applies to 2005 models only, 2006 are supposed to be upgraded unless it's an early build. Read the Campaign with your dealer. It states ALL SERIAL NUMBERS and the termination date is 2008-10-03. If you call BRP customer support and say one of your children has suffered frost bite in their hands, they will take notice. BRP has had enough grief over the first generation Modular Helmets and frost bite.[/b]
Thanks for the info TD. Mine is an 05. I messed around with it a little yesterday and wasnt able to get anything more figured out. I did snap some pics yesterday, will upload them later tonight. The one warmer is good for sure I think. I was able to get a good ohm reading on it, but I cant get anything on the other, not sure if I was getting the correct wires though.

May just deal with it this winter and drop it off in the spring after the season. I take it now to the dealer, may not get it back till spring. May have to say the wifes fingers got some frost bite!! Thanks again Simon!!!

Greg
 

·
Registered
Joined
·
10 Posts
I also have no power to the seat. I did however remove the seat, take it into the garage and connect it directly to a 12 v power supply..You could probably cook hotdogs on the grips now, so apparently the heating elements in the grips are OK..Now if I could only get power back to them.. I too hate this electrical ####....
 

·
Registered
Joined
·
1,708 Posts
Discussion Starter #18
Paco, I originally didnt have power to the seat either. The connector that plugs into the seat, the one with just 2 wires, I didnt have power coming out there. I was able to find another connector in under the black plastic piece that covers the main seat. I had to dig a little bit there was another one there that had power coming out of it. Maybe worth checking into.
 

·
Registered
Joined
·
10 Posts
XCR,
Are you refering to that black plastic cover that clips down just behind the base of the main seat? I lifted that off and found more wires and another plug just sitting there connected to nothing. Or did you find this other, unused connector, under the main driver seat ?

Thanks for all these questions paul
 

·
Registered
Joined
·
2,782 Posts
Guys, I have checked all the schematics from 2004 til 2007 and none include passenger seat wiring. I'm going to look for a suppliment manual at the dealer on Monday. I imagine the paperwork which came with a passenger hand warmer kit will give clues as to how is is supposed to be wired.
 
1 - 20 of 24 Posts
Top