Snowmobile World banner

1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello
Last week I acquired an older sled that is great looking and great running! It has two problems though!
1) When driving it seems to rev really high in the rpm but not really going very fast like 6-7000 rpm but only doing like 30-40 mph. It seems to be a clutch problem. Is their a way to adjust it? If so can someone please help me with a few steps to get me going? Is it the drive clutch on the engine that needs adjustment or the secondary clutch?
2) I can’t seem to get the choke to work. I removed the carb but it doesn’t have a flap for the choke, just a flap for the throttle. The choke cable runs inside the carb and i cant even unhook the cable just adjust it with the adjuster nut.

I know people are going to say oh it’s an old sled let it be. But no way it starts first pull and runs great and i just got a new track on it and i love it!
If someone had a downloadable copy of the manual or scanned copy that would be awesome seeing as I can’t find one anywhere!! Please help ASAP before the snow goes away!!
RJ
[email protected]
Email me at the address above please!!
Help Adjust Yamaha 400 SS Clutch 1981
 

·
Registered
Joined
·
90 Posts
i just addressed this problem on my friends ss. reduce the secondary spring pre tension , i think i went from hole# 3 to hole#1. sand the clutch faces it will help the problem. as far as chokes, do yourself a favor and drill and tap the carb for a skidoo type primer.
 
1 - 2 of 2 Posts
Top