Snowmobile World banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Thanks eveyone for the Advice, but what seems to be Happening is the plugs are getting fluded and I take them out clean them off and still nothing. I have the choke up, I am not holding the Throttle down. I am spraying starter Fluid into the air Intake. HELP I am about to blow the thing up!

Stinger what type of Jets did you Install?

Somebody suggested adding a primer what does everyone think?

Thanks Everyone
 

·
Registered
Joined
·
3,910 Posts
Snah.  

Ok first of.  Flooded has to do with to much fuel and oil in the combstion chamber.  

Whats happening to your plugs is called Fouling.  

First thing you want to do is make sure you have a spark.  To do this pull the plugs from the engine and hold them up against the block.  Use pliers with rubber handles to hold the plugs down dont hold them with your hands.  Then turn on all the keys and kill switches and have a friend pull the cord.  If you see a nice spark then its not an ignition problem.  

What i would do is go up to your machine and pull the plugs.  With no sparkplugs in the holes turn the key to the off position and pull the engine over 6 times fast (Like your trying to start it.)  

Then put in New plugs and screw them in.  Dont use any choke just pull hard and have someone or if you can do it apply 1/4 throttle.  If it starts then thats probably the end of your problem.  If it doesnt then you might have a failed piston or a bad carb.  

Dont use any more starting fluid.  

Like i said i think your problem is failed plugs.  It happened to me a few times.  The machine just wouldnt start.  Plugs spark but not when there in the engine under compression.  

Goodluck.
 
1 - 2 of 2 Posts
Top