Snowmobile World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2,782 Posts
Mark, try speeding up your idle and leaning out your idle mixture a little bit. Sounds like the bare beginnings of loading up. As goofy as it sounds, once fully warmed up try to limit idle times to a minimum. Some Cats suffer from the the bottom end remaining cool (That's a good thing) after riding in deep snow and the first idle session, the cases get a little raw fuel in them and dirty the next accelleration cycle. I wouldn't mess too much with pilot or jetting because it sounds like you'll have some wiggle room for when the mercury drops deeper with you current settings. Now if this is a setup that never gave any issues before, check the variables like fuel quality, snow / water ingestion (water always likes to mess with tiny pilot jet orifices). Try a little Iso and see if that clears it up.
 

·
Registered
Joined
·
2,885 Posts
Discussion Starter #5
I have the iso in the boss for ya[/b]

thanks buddy . well I hate making a lot of changes all at once but was forced to . first a new clutch , along with a lower engaging callibration . much smoother and hopefully the top end r`s are where I think they will be , carb`s... 200 more rpms at idle , a fresh sync and 1.25 turns out on enrichment screws from 1.75 . we will see lol
 

·
Registered
Joined
·
7 Posts
thanks buddy . well I hate making a lot of changes all at once but was forced to . first a new clutch , along with a lower engaging callibration . much smoother and hopefully the top end r`s are where I think they will be , carb`s... 200 more rpms at idle , a fresh sync and 1.25 turns out on enrichment screws from 1.75 . we will see lol[/b]
if you are still having the problem. check the magnetic switch's on the carb's. i had one go bad on me and that is the same thing mine was doing.. changed it and now it is just flying out of the hole..
 
1 - 6 of 6 Posts
Top