Snowmobile World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I dont wanna make this post too long.. so here goes.
I have a 91 Exciter 570 L/C . I was on the trails the other day with a buddy for about 1 1/2 hours of running. We stopped in the woods to take a drink and a break so the machine started to cool. Then we fired them up and started to head up north more. Well after about 15 minutes I was heading on a straight away and accelarated.... few seconds after I did.. I heard a bang.. and then she just died right there. So I took off the belt, now when I turn the clutch it wont turn all the way.. the left side of the motor actually moves up when it hits. and I cant pull the starter or nothing. Do I need a rebuild? and how much is that going to cost me. I have only been out about 4 times this year.. and bought the sled off a guy 4 months ago... I AM REALLY PISSED ... this guys going to get an ear full. My cuz that I was out with says.... YAMAHA teasing me the whole way home as he doubled me on his 98 Skidoo. Then says leave it out in the feild, but ya dont have to worry about anyone taking it.. cause who would want one.. haha .... Looks like Yamaha let me down.
 

·
Registered
Joined
·
3,910 Posts
HAHA.  Leave it on the trail.  I use that one all the time.

Dont worry it was just your turn.  If your patient you will get your chance to.  

As for the damage.  It sounds really bad.  I might just look for a new engine.  But i really dont know.  

Sound like it wasnt stored properly in summer.
 
1 - 4 of 4 Posts
Top