Snowmobile World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter #1
I had a shop put new hyfex on 98mxz670 and they cut them on a 45% angle(at the back), and it looks like they cut them short because there is a 1/2inch or more of the rail showing, is this how they should be installed,? should'nt they go all the way to the end of the rail? Thank you Dave.
 

·
Registered
Joined
·
11,658 Posts
they did it almost perfect. you want that angle cut so that you can turn the track in reverse and not pull off any of the track clips. also if the sliders are too long not angled you will hear the clips clatter off of the end of the sliders.
 

·
Registered
Joined
·
193 Posts
Discussion Starter #3
they did it almost perfect. you want that angle cut so that you can turn the track in reverse and not pull off any of the track clips. also if the sliders are too long not angled you will hear the clips clatter off of the end of the sliders.[/b]
Thanks agian guy's. I seen the rail showing I thought that was the clicking metal sound under track, i took off all bogies there all rollin free, cant find what making that noise, I put a hose to my ear under track, and it seems to be by the drive wheels, i think its a bearing but i had the hose rite up in the tunnel next to bearings and it does not get louder, im haveing trouble trying to pin point this clatter realy dont want to pull all the bearings to find out. my chain was way loose thought it was that but still clatering. has to be a bearing being chewed i hear it but cant find witch one. Thank's Crash Dummy
 

·
Registered
Joined
·
2,885 Posts
look at your rail tips( no ... the front lol). do the plastic endcaps have big gouges in them . there is your sound/vibe . btw you can turn the ends of the upper rear shaft to 1" and not need to purchase those ####### size overpriced bearings from Fast . just a standard 6205,just put a shim in behind the bearing to protect it from the outer tube hitting the side of the bearing . M
 
1 - 4 of 4 Posts
Top