Snowmobile World banner

1 - 3 of 3 Posts

·
Registered
Joined
·
193 Posts
Discussion Starter #1
my strap in the front of the M10 rear suspension come off, and i went to put another bolt in and notice that the bracket that holds the straps, has a square hole, lost the bolt on the trail not shure what it looks like, was just going to use a bolt with 1 inch washers,would this hurt anything? and how do you take the spring presshure off to line it up with the holes on strap.Thanks Dave from madison.
 

·
Registered
Joined
·
1,139 Posts
Try lifting up the rear of the sled and then put a block of wood or something under the front section of the track..Once you let down the rear it should compress the front enough to get your limiter strap back on...As for the square hole it sounds like it may have had a "carriage bolt" type bolt that has a square section just underneath the head ..You should be able to get one in any hardware store but a normal bolt should work ok too as long as it fits tightly in the hole..The good thing about the carriage bolt it you don't have to hold the bolt with a wrench to tighten the nut,especially if its in a tight spot.
 

·
Registered
Joined
·
193 Posts
Discussion Starter #3
Try lifting up the rear of the sled and then put a block of wood or something under the front section of the track..Once you let down the rear it should compress the front enough to get your limiter strap back on...As for the square hole it sounds like it may have had a "carriage bolt" type bolt that has a square section just underneath the head ..You should be able to get one in any hardware store but a normal bolt should work ok too as long as it fits tightly in the hole..The good thing about the carriage bolt it you don't have to hold the bolt with a wrench to tighten the nut,especially if its in a tight spot.[/b]
THANK YOU; 'OLDYELLER'
 
1 - 3 of 3 Posts
Top