Snowmobile World banner

1 - 10 of 10 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
Does the 2001 Mach Z have a thermostat??
 

·
Registered
Joined
·
2,422 Posts
Remove the 2 10mm bolts in the stat housing on top of the head to find out. My 2000 didn't, it ran about 1/4" farther up the gauge [hotter]. Now it has one and the heating problems are solved! What the he!! was Doo thinking? Someone once said they were running to cold and cold seizing, ya right, maybe in northern Alaska!
 

·
Registered
Joined
·
142 Posts
It shouldn't, they took the thermostats out in 1999 for the ck3 chassis.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #4
Mine has no Thermostat.  The reason I asked is because I had a problem with the 01 motor.. Bomby determined it had a faulty center bearing/seal after it took out 2 center pistons. I had a new 02 motor installed free except for labor.. When the sled took out the center piston the first time and I got it back together it would flow coolant from the small hose on top of the thermostat housing into the overflow tank... I thought it did this because it had a themostat? Now with the new 02 motor there is no coolant flowing from that hose when I start it..  Also I have a small dribble of coolant around the hose that goes into the pump at the front of the motor.  Can anyone tell me how the coolant system flows on this sled?
Thanks
 

·
Registered
Joined
·
226 Posts
Discussion Starter #5
I checked out the online Doo Microfiche and yes it looks like they stopped putting a thermostat in the 809 after 1998. All the 99 and up show a plug in the top of the housing where as mine has the hose that runs to the tank.. Could this be due to the reverse flow of the coolant when I use my RER??


Evel
 

·
Registered
Joined
·
756 Posts
doubt it
 

·
Registered
Joined
·
2,422 Posts
Evel, pinch the hose off and pull the themostat housing off, or take the bleeder screw out and run a wire down and see how far it goes, if it's over 2" I would say no stat. You wont lose hardly any fluid.
 

·
Registered
Joined
·
226 Posts
Discussion Starter #8
I already removed the housing.. No thermostat.. Also I "don't" have a bleeder screw.. There is a 90 degree barbed fitting in it that has a hose that runs to the overflow tank.. I am wondering why my sled has this? It does not show up on the Doo microfich..  Shows a plug/bleeder like you claim. It only goes to 2000 so maybe they changed it in 2001?
 

·
Registered
Joined
·
176 Posts
my 99 mach1 dose not have the hose not sure on the stat just got her end of last season but the friend I bought it from also has a 2000 machz and it has the hose you are talking about.both sleds are rer I`ll aks my bud he works at a doo shop,but there are many mach owners on here I`am sure they know why.
 

·
Registered
Joined
·
316 Posts
Skidoo made changes to the 2000 model after finding out the 99 was just too fast. It seems that the other manufacturers were going to go to 1100cc triples if Doo didn't slow down the 809 engined sleds. So, they slowed it down a tad. That's why i love my 99 809!!!  Ok, so this story is BS, I can dream can't I?
?
 
1 - 10 of 10 Posts
Top