Snowmobile World banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
1997 grand touring 583 2 stroke premix
So had this gt for 2 years and always run good I went for a 80 km ride to town I live in bumf nfld Canada and a little over 3/8 way there I was cursing on straight (doin like 100 km) then she just lost power and shut off I checked spark and both where great so I went to check com on each plug one at time and didnt realize key was on when I pulled it, she started up with only one plug so I figured she's good most over over heated or something so I put other plug in and pulled and nothing took that plg out again and first pull I checked muffler for blockage but nothing any one know if these machines have sleeves in ( piston sleeves )top end??? If so if she was hot could it move and block exhaust cuz soon as u put finger or plug on hole she shuts off like she has to much compression I'm very confused I drove her home on one plug was low on power but she worked if u have any idea plz let me know this skidoo is how I go shopping everything and need to get her going to get around
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
What would cause a cylinder to go dead and how do I fix it. I know the piston is still moving. And when I have her running with one plug in there's lots of com coming out of the spark plug hole. The air coming out of the plug hole is as strong as my air compressor. I barley got any thing coming out of my muffler I checked for blockage but could only check from after the manifold cuz I was in the woods
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
So I checked compression all was good then I said screw it and threw some gas oil mix into her spark plug hole and put plug back in and pulled her and she started right up so I think the carb is plugged and that's what did it
 
1 - 8 of 8 Posts
Top