Snowmobile World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I have an 02 ZR440 SnoPro and just recently my tail light/brake light, tether cord and shutoff switch stopped working. Everything else works! It is not a part failure I have checked all of the parts themselves out. It has to be a common wire or something. I traced all of the wiring and it all looks intact, but I am not sure what type of voltage I should be getting through which wire.

Any ideas on where to go next? I will take it to my dealer as a last resort, I know I will spend an arm and a leg if I do that, so any help is appreciated.

Thanks!
 

·
Registered
Joined
·
19 Posts
sounds to me like you have a connector that came off, check at the steering post for a possible connector that came apart, not necessarily all the way apart either, you could also try wiggling the harnesses and see if anything works, wait, didn't you say tether cord, the machine will run without the tether cord working??
 

·
Registered
Joined
·
177 Posts
I would for sure check all of the connectors you can find,,,,,,, Iam sure youll find it to be something stupid as a lose connector
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
I'll keep checking all of the connections for a possible loose connection.

Firecat_freak - Yes right now the machine runs with the tether cord removed.
 

·
Registered
Joined
·
3,183 Posts
If it runs without the tether cord, then I would think there must be a wire crossed somewhere (bypassing all those electrical components.)
 

·
Registered
Joined
·
333 Posts
With the engine running but not for too long,take a grounded test light(12 volt) and touch the pointy end to your handle bar post,engine block,light mounts, any place there is a bad ground will light the test light even on something that should have no power (like the tunnel) if you have a bad ground.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
I figured out the problem. I have a shorted thumb warmer switch. When you click it on med. or high, it shorts out and causes the tether, kill switch and tail light no to work. Oh well guess I'll be shelling out some more cahs for those wonderful AC repalcement parts!

Thanks for all the help!
 
1 - 8 of 8 Posts
Top