Snowmobile World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1
hello....um im having a lil trouble taking the driveshaft off on my 1995 storm....now i have taken off the lower sprocket with the circle clip and washer and the speedo housing and bearing...so now it slides back and fourth, but now heres the problem every time i slide it back and fourth it seems like it gets caught on something form the gear side and i dont no wut it is...I NEED UR HELP>>>IM GOING TO GO CRAZY!!!!! :cussing:
 

·
Registered
Joined
·
2,560 Posts
It's been a while since I've done what you are doing, but thinking that if that driveshaft has 4 drivers on it, the chaincase needs to be disconnected, slide out a little (minimum, some remove it completely) to clear that driveshaft. While doing that, maybe you can spot what you're hanging up on.
 

·
Registered
Joined
·
2,560 Posts
Take a breath. Thinking you'll need to be a little more specific.

You say you have the chaincase and the speedo housing both off. Not sure how you could have anything else that could be in your way?
 

·
Registered
Joined
·
2,032 Posts
if you move it toward the chaincase first it should come out of the speedo drive side and then you can pull it out of the chaincase side.
 

·
Registered
Joined
·
1,708 Posts
if you move it toward the chaincase first it should come out of the speedo drive side and then you can pull it out of the chaincase side.[/b]
Yes like tifa said!! Pay attention to him and Michahicks, they really know there Polaris stufff!!
 
1 - 8 of 8 Posts
Top