Snowmobile World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
508 Posts
Discussion Starter #1
Wifes cousing just bought a 96 XCR 600 tripple. When it idles it is fine. When he rides the sled and a good rate of speed, coolant starts shooting out of the overflow cap hole. The sled was well taken care of by its previous owner. It has 2,500 miles. The temp light has never come on. The overflow tank is NOT over filled I made sure of that. We did all we could to relieve the system of any air bubbles, but this didn't help. The sled still acts like old faithful. Could this be as simple as a bad radiator cap? Are these fairly common to fail? Anything else I can check for?
 

·
Registered
Joined
·
96 Posts
Have the cap tested, I think they need to hold 13psi or buy a new one. Gotta be fairly cheap. It's the next logical step.
 

·
Registered
Joined
·
87 Posts
I've had this happen before. Caps are pretty cheap. Go buy one and try it out near your house. That way you'll know if it works or not before you get out on some expensive trip and waste your time broke down on the side of the trail.....
 

·
Registered
Joined
·
508 Posts
Discussion Starter #4
Originally posted by Keving@Oct 29 2002, 04:07 PM
Have the cap tested, I think they need to hold 13psi or buy a new one. Gotta be fairly cheap. It's the next logical step.
The cap on this sled said 10 psi, is this right? Other posts in the Polaris forum always seem to mention 13 psi caps as well. My arctic cat cap is 13 psi. I'm beginning to wonder if this sled has the wrong cap on it?
 

·
Registered
Joined
·
508 Posts
Discussion Starter #6
Originally posted by pnewbern@Oct 30 2002, 02:54 PM
Hey didnt you post on rec sport? I had a xcr 600 xlt and it had this problem and it was THE HEAD GASKET.
PNEWBERN
Could you tell it was the head gasket by looking at the plugs, smelling antifreeze in the exhaust, seeing any leaks around the heads, etc? Is there any way to tell without taking the head off?
 

·
Registered
Joined
·
78 Posts
I have the same darn problem on the same sled. 96 xcr 600 SP. I'm going to buy a new cap and hate to take the heads off and re bleed everything etc if I don't have to?

What solved the overflow issue on yours?

Is the drain hose/overflow hose suppose to go to an overflow tank?
 

·
Registered
Joined
·
650 Posts
The head gasket is a rubber o-ring.

Yes, this could be your problem.

Look in your over flow bottle and see if you have a black film on top of the coolant or any black dots floating around.

When the o-rings break apart pieces of it work into the coolant.

You could also do a compression check.

Not all that uncommon for the head o-rings to leak and this will cause coolant to bubble over.
 
1 - 8 of 8 Posts
Top