Snowmobile World banner

1 - 20 of 24 Posts

·
Registered
Joined
·
4,316 Posts
Is that your chicken raisin' the roof there Mach?  
 
 
 

·
Registered
Joined
·
1,859 Posts
Discussion Starter #4
lol..... believe me it is harder the u would think to hook up on asphalt.....ive always strapped my sled right down like on ice and not only me but pretty much everyone eles have had a hard time hooking. so this year i tried the approach that it is more like snow instead of ice . once i got my overflow to stop leaking down on my track
 it did start to hook. but need more test time....lol
 

·
Registered
Joined
·
2,422 Posts
OH, the power of the 809!

Isn't wonderful!
 

·
Registered
Joined
·
8 Posts
Hey Man that is one awesome machine!!!!!!
the yamaha beside u looks pretty competitive!!! LOL
 

·
Registered
Joined
·
11,658 Posts
not that i would ever want to try that but it sure looks like a wild ride.  
 

·
Registered
Joined
·
2,422 Posts
Com'on Paul! Dont be such a puss! My heart started to flutter when I seen that pic. I would kiss the queen's hind end to ride that baby!
 

·
Registered
Joined
·
11,658 Posts
mikadoo,
 you must like the thought because i wouldn't kiss her on the lips. lol
 

·
Registered
Joined
·
2,422 Posts
Oh ya B-A-B-Y
 
 
 

·
Registered
Joined
·
14 Posts
:D hey buddie good to see yah on line, you should of put a pic of me and u on there instead of James' Yamaha. I better stick a pic on. Talk to you at the banquet in Ottawa if you go.
 

Attachments

·
Registered
Joined
·
272 Posts
i asphalt drag to and that sled was not hooking huh?the mach are a hard sled to get to stay flat. i almost bet that the yami got ya to 330?
 

·
Registered
Joined
·
1,859 Posts
Discussion Starter #15
hey guys how are yah... yeah you said it right the mach`s are very hard to get to hook so thats why in this pick u can see its way up there.lol what is said if setting up like on ice dont work(very hard ) well mabe ill try to set up like on snow..... and beleive it or not i found that it did hook better i just had some other things going on......lol.. but i can do that in this circuit cause its only 660 if it was the 1/4 i would drop it but then again i might just test it like that...good to see yah zasphalt
 

·
Registered
Joined
·
660 Posts
That picture is so funny!

IT looks like the v-max is:

1. Not running,
2. Too heavy to even decompress the front struts!
3. Someone played a trick on him and the throttle cable is missing. :p
 

·
Registered
Joined
·
60 Posts
gotta love the drags.... I will post up some pics after the snow in drags at the lanters..
 

·
Registered
Joined
·
1,012 Posts
Nice pic. Looks like you have a real nice track there! :thumbsup:
 
1 - 20 of 24 Posts
Top