Snowmobile World banner

1 - 17 of 17 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Can anyone help with 2000 500 XC? My sled will start but after about 30 seconds it just dies! I dont know what do anymore i changed the spark plugs, cleaned the carbs, checked my fuel tank and fuel lines! I would much appreciate if anyone can help me!
 

·
Registered
Joined
·
1,558 Posts
are the oi lines all hokked up. something similar happened to me when an oil line came off. i melted down the motor though, hope that doesnt happen to you. also maybe the carbs need to be adjusted some. maybe a bad fuel filter. could be a million things.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
are the oi lines all hokked up. something similar happened to me when an oil line came off. i melted down the motor though, hope that doesnt happen to you. also maybe the carbs need to be adjusted some. maybe a bad fuel filter. could be a million things.[/b]
Yeah i have all the oil injection lines hooked up the carbs are good i just cleaned them about 10 minutes ago! And the fuel filter is fine cause i just had to replace a fuel line in the tank because the ethnoel from the gas ate away my old fuel line that is connected to the klunk in the tank! I dont know anymore maybe an engine swap soon!
 

·
Registered
Joined
·
1,558 Posts
if its a ves maybe check them they could be really dirty. maybe a bad ring? dont really know.
 

·
Registered
Joined
·
267 Posts
will it restart right away after it dies?
 

·
Registered
Joined
·
476 Posts
We all like to tell you to check the simple and cheap things before you tackle a serious engine tear down. The symptoms you have been telling us sounds like a clogged pilot jet. You did take the pilot / low speed jet out, on both carbs, and made sure you could see thru them, right? If not, use my patented pilot cleaning tool :cool: , a twist tie with about 1 1/2 inches of the plastic stripped back, and some spray Gumout to complete you carb cleaning.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
We all like to tell you to check the simple and cheap things before you tackle a serious engine tear down. The symptoms you have been telling us sounds like a clogged pilot jet. You did take the pilot / low speed jet out, on both carbs, and made sure you could see thru them, right? If not, use my patented pilot cleaning tool :cool: , a twist tie with about 1 1/2 inches of the plastic stripped back, and some spray Gumout to complete you carb cleaning.[/b]
Oh yes i ripped both carbs apart cleaned all the jets could clearly see through them! Its got be in the carbs but i dont know what it is thought its so wierd! Maybe the lower crank case!
 

·
Registered
Joined
·
1,558 Posts
Oh yes i ripped both carbs apart cleaned all the jets could clearly see through them! Its got be in the carbs but i dont know what it is thought its so wierd! Maybe the lower crank case![/b]
maybe check the thrrotle cable tension setting the idle? could be loosen. had it happen before where the nut lossen and it just kind hanging there. also maybe the air screw?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #13
maybe check the thrrotle cable tension setting the idle? could be loosen. had it happen before where the nut lossen and it just kind hanging there. also maybe the air screw?[/b]
Bolth cables are good for the thrrotle and choke!
 

·
Registered
Joined
·
30 Posts
Bolth cables are good for the thrrotle and choke![/b]
A lot of the people here have way more experience than me but after reading the posts I feel like it is a fuel delivery problem. Have you checked the fuel pump? Is the impulse line installed and not leaky? Maybe a rebuild kit would fix it all up?

Boegey
 

·
Registered
Joined
·
6 Posts
A lot of the people here have way more experience than me but after reading the posts I feel like it is a fuel delivery problem. Have you checked the fuel pump? Is the impulse line installed and not leaky? Maybe a rebuild kit would fix it all up?

Boegey[/b]
Same thing is happening on my 1990 500, could it be the crankcase seals, was my question? Mine runs fine on the cylinder not next to the clutch though.........but two cylinders would be better than one........
 
1 - 17 of 17 Posts
Top