Snowmobile World banner

1 - 6 of 6 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter #1
Quick question hopefully someone will have a awnser too without having to reference there sled, but I beleive that my exhaust manifolds on my mag side and center may be switched around. Every other year Ive been taking the pipes off and silencer, give them a once over in the sandblaster then hit them with the high temp paint for appearance reasons and the Mag pipe is always a pain in the butt to get off and on. Until yesterday ive just delt with it until i looked closely at these manifolds and realized how different they all are. The PTO side seems to correct or atleast make the most sense, but the other too seem like they should be flopped. Hopefully the picture is clear enough to make heads or tails out of. Ive looked at the parts diagrams and they are not detailed enough to make the call on. Any help would be appreciated. Thanks

-Brett

The Picture will have to be enlarged to read the description text =)

[attachment=40154:EXAUST_QUESTION.JPG]
 

Attachments

·
Registered
Joined
·
57 Posts
Quick question hopefully someone will have a awnser too without having to reference there sled, but I beleive that my exhaust manifolds on my mag side and center may be switched around. Every other year Ive been taking the pipes off and silencer, give them a once over in the sandblaster then hit them with the high temp paint for appearance reasons and the Mag pipe is always a pain in the butt to get off and on. Until yesterday ive just delt with it until i looked closely at these manifolds and realized how different they all are. The PTO side seems to correct or atleast make the most sense, but the other too seem like they should be flopped. Hopefully the picture is clear enough to make heads or tails out of. Ive looked at the parts diagrams and they are not detailed enough to make the call on. Any help would be appreciated. Thanks

-Brett

The Picture will have to be enlarged to read the description text =)

[attachment=40154:EXAUST_QUESTION.JPG][/b]
Well i dont thank u could put them on wrong. The mag side pipe is hard to get on, not sure how to help u mabey i could take a pic of mine put together, so u could compare. Nice sled by the way, good old tripple tripple very fast sleds.
 

·
Registered
Joined
·
57 Posts
Well i dont thank u could put them on wrong. The mag side pipe is hard to get on, not sure how to help u mabey i could take a pic of mine put together, so u could compare. Nice sled by the way, good old tripple tripple very fast sleds.[/b]
i take that back i thought u were talking about the pipes. i have a pic but can not figure out how to get it on here.
 

·
Registered
Joined
·
71 Posts
Discussion Starter #4
Should be able to click on "browse" below, select the picture you choose to post, then click on "upload" after its uploaded right above the "upload" button it should say manage current attachments (1). Click on that, then select the + symbol to add it. Thanks for the help!
 

·
Registered
Joined
·
57 Posts
Should be able to click on "browse" below, select the picture you choose to post, then click on "upload" after its uploaded right above the "upload" button it should say manage current attachments (1). Click on that, then select the + symbol to add it. Thanks for the help![/b]
[attachment=40198:jeremypolaris.jpg]
there if it is to small i can try again
 

Attachments

·
Registered
Joined
·
71 Posts
Discussion Starter #6
ended up switching them and it was definatly wrong before. Pipes went back on like a glove. Thanks for the help all.
 
1 - 6 of 6 Posts
Top