Snowmobile World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
I recently bought a used 2000 Powder Special 600EFI for deep snow trips, and as a second sled.

I have gone thru is completely, and it in in good shape and pretty much ready to go. However, it does something strange that none of my other cats have done. When you manually lift up on the front of the sled, the ski's toe in and when you push down on the front, they toe out. And, I don't mean slightly, from toe in to toe out, the distance between the tips of the ski's vary almost a foot.

Everything is tight, there is no looseness in the steering or in the linkage. I have looked carefully, and there doesn't seem to be any structural damage or anything that has changed the steering geometry. It does have something to do with the steering rods as that is what is pushing the skis in and out as the front of the sled moves up and down.

So, anyone have any insight on this? It is the first Powder special I have owned, so as far as I know, it could even be normal. None of my other cats with the same AWS front suspension ever did this tho.
 

·
Registered
Joined
·
1,558 Posts
I recently bought a used 2000 Powder Special 600EFI for deep snow trips, and as a second sled.

I have gone thru is completely, and it in in good shape and pretty much ready to go. However, it does something strange that none of my other cats have done. When you manually lift up on the front of the sled, the ski's toe in and when you push down on the front, they toe out. And, I don't mean slightly, from toe in to toe out, the distance between the tips of the ski's vary almost a foot.

Everything is tight, there is no looseness in the steering or in the linkage. I have looked carefully, and there doesn't seem to be any structural damage or anything that has changed the steering geometry. It does have something to do with the steering rods as that is what is pushing the skis in and out as the front of the sled moves up and down.

So, anyone have any insight on this? It is the first Powder special I have owned, so as far as I know, it could even be normal. None of my other cats with the same AWS front suspension ever did this tho.[/b]
you need to adjust the stindles/sterring arms. they are not alined right
 

·
Registered
Joined
·
142 Posts
Discussion Starter #3
you need to adjust the stindles/sterring arms. they are not alined right[/b]
Thanks for the reply, but I'm not sure what you mean. the ski's are straight and aligned when sitting on concrete. It's only when the front suspension is compressed or lifted that the ski's toe out or in
 

·
Registered
Joined
·
1,558 Posts
Thanks for the reply, but I'm not sure what you mean. the ski's are straight and aligned when sitting on concrete. It's only when the front suspension is compressed or lifted that the ski's toe out or in[/b]
well you have the spindles with a like arm on top. this arm connects to the tie rod then the tie rod to the steering. well these spindle arms like need to be straight forward align straight with the skis.from the connection point through the spindle to the ski tip should be a straight line. them from there you need to adjust the tie rod to work with this. having spindles lines up right will give you even turn and even rise with both skis. also your skis should point just a tiny tiny bit out because this will get rid of darting and you neve want your tips pointing in. try this and get back to me. im more of a polaris man but fron what i know about ac you need to do this, smae with a polaris
 

·
Premium Member
Joined
·
709 Posts
With a used sled, especially a mountain rig, there is a good chance it was crashed and improperly repaired. On my RMK the previous owner had put on the wrong size tie rods (two different sizes, neither correct, and they are supposed to be the same) and it was wacky. If you have the wrong parts on there it might be hard to tell by looking. I only figured it out because my tie rods were also stripped-out and one day my steering failed, and when I replaced them with correct new OEM tie-rods, they were totally different from what was on there. That fixed all the wackiness.

Like TSS said, check that the steering arms (on top of the spindles) are aligned with the ski. If you find that you have to make major adjustments in the tie rod just to get it near what it's supposed to be then you have a problem. Wish I could be specific but what you describe should not be happening under normal circumstances.
 
1 - 5 of 5 Posts
Top