Snowmobile World banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
In setting the rear suspension spring for pre-load on my rev 600 x, I can't get the coupler block centered between the stops. My weight is 175. According to the manual the rear spring is the only way to set the pre-load. There are four settings for the spring and the stock setting is at 1 (softest). Any suggestions??
 

·
Registered
Joined
·
678 Posts
I have an '03 MXZ 500, weigh 175 lbs. and have the same thing, if I stiffen the preload it's too far forward, and if I loosten it, it's too far back. We just must be that inbetween weight.

I set my preload to the chart and put the block fat side down, that gets me closest to the middle, it should be good, but I need some snow to find out for sure. :)
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I can't even get the block near the rear stop. It goes just past the front stop but not centered. The suspension sags only about 3/4 of an inch. Maybe because it is an X!
 

·
Registered
Joined
·
678 Posts
Very well could be, it would make sense. That stiff I'm sure is good for snoX, Might be rough on trails though unless you're one of those balls to the walls 100% of the time fellows! :D
 

·
Registered
Joined
·
191 Posts
My REV X 800 also has very little sag. Its at the softest setting all the way around. I weigh ~200 lbs. I figure to leave it soft (help break the suspension in a bit quicker) and then make some adjustments once I get a few miles on it.
 
1 - 5 of 5 Posts
Top