Snowmobile World banner

1 - 10 of 10 Posts

·
Registered
Joined
·
55 Posts
Discussion Starter #1
Hello all
Just took my 03 Summit 800 HO for the first ride. The sled ran really well, only problem is that the starter rewind broke after 40 miles. Any one else had any problems with this on thier 03 sled. Locally we have had at least 3 break already. The dealer already told me they would take care of it with no problems, but is this something that is really going to be an issue this year. Does anyone have any input on this. Thanks in advance and take care
;) ;)
 

·
Registered
Joined
·
678 Posts
They just break while riding? or are they getting cut on something?

I haven't had any trouble with mine, but I only put .5 mile on it.
 

·
Registered
Joined
·
55 Posts
Discussion Starter #4
The rewind broke internally and the cogs would not catch inside to turn the engine over. Sounds like this is something that needs to remidied really soon.
 

·
Registered
Joined
·
376 Posts
I had poblems with mine, but not until 4000 miles. Ski doo replaced it with the updated version, which I assume thats the one you have on your 03. They dealership told me I wouldn't have any more problems again, I hope there not wrong.
 

·
Registered
Joined
·
4,659 Posts
We replaced the recoil under warranty yesterday on a 02 mxz800 gade. The nubs or cogs inside melted last year due too the blue flame syndrome, too much heat.. They replaced it with a new style recoil and a new heat shield for the one side of the muffler. Last year in our pack there was 5 2002 mxz800's. This was the only one that had a recoil malfunction, and they all had blue flames at one time or another. Bombi is replacing Ladyk's Pipe shield and her exhaust side vent is melted. I am going to try to get them to replace the lady's recoil. Looks like i got thirty days to dooit under warranty or i will have to rely on the Goodwill warranty later.
 

·
Registered
Joined
·
678 Posts
I feel for you guys! I'm just glad it's only an 800 problem and not a series 3 problem.
 

·
Registered
Joined
·
8 Posts
i got a new 2003 rev 800 sport this year..but last year i had a 02 mxz x 800 two tone..the rewind acted funny for about 200 miles..skiping after it warmed.almost not starting it a few times even..then all the sudden around 500 miles it never did it again..my friends 01 mxz x with zero miles too never had one problem with his rewind..i hope the rev dont have rewind problems too..now it just needs to snow!! :D
 

·
Registered
Joined
·
4,869 Posts
SkiDoo can NOT build a recoil if their life depended on it :cussing:

Every Doo I have ever own had recoil problem,its the cheap internal plastic parts :cussing:
 
1 - 10 of 10 Posts
Top