Snowmobile World banner

1 - 15 of 15 Posts

·
Registered
Joined
·
70 Posts
Discussion Starter #1
i was out today @ 6 am snowmobiling i felt like waking up the neighbours. my stx ws not running well. it would not idle and it would over heat and i had to rev it up to 7000RPM for it to ingage and start to move. it has always had a problem with overheating but it has never had problems idling or engaging. i haven't put new plugs in yet so maybe thats what the idling problem is. have any of you guys have any ideas on how to fix this?
 

·
Registered
Joined
·
417 Posts
Was this when you first left the yard? Frozen track and or ski's? Sounds like it's running on one cylinder. No idle, lots of R's to get it rolling. You say it has 500 K's. 583 STX. 94, 95 right? How did it run when you got it rocking?
 

·
Registered
Joined
·
70 Posts
Discussion Starter #5
nothing was frozen its been in my heated garage since march, since we got that snow today i wanted to run it. could it just be a bad plug? i didn't really check them. this has happened on my arctic cat a couple of times where it was only running on one cylinder but it sounded different (more quite) and i changed both plugs and it ran beautyful. it sounded like it always does. it ran pretty nice when it was rolling just you could not let off the throttle.
 

·
Registered
Joined
·
70 Posts
Discussion Starter #7
damn i don't remember that, i'm just going to go to canadian tires and buy some new pluggs tomorrow and see. also is it normal for that engine to run hot? i would be running in 3 feet for powder and the needle would still be near the top of the gauge.
 

·
Registered
Joined
·
417 Posts
If a crank seal is gone (most likely the PTO). That cylinder is going to run lean. More heat. Did it do this last year? What colour are the plugs now? Have you blown any belts lately?
 

·
Registered
Joined
·
4,869 Posts
Have you had the clutch apart???

How do you know its over heating???Temp gauge???

Did you clean the carbs???

What year 94? 95? 96?

Sounds like clutch if you have to rev it to 7000 to engage,

Mine engages at 4500rpm :)



Whats the top rpm???
 

·
Registered
Joined
·
1,139 Posts
I had a 94 STX and the needles in the carbs had to be dropped one notch It fouled plugs like crazy when I first got it and was a pig on gas.The sled always ran awesome after dropping the needles.18,000 km and never changed anything but plugs and a belt.Put a rotary valve out of a formula Z in it and it would beat all 583s in every radar run I was ever in.Run your engine for a while and feel the heat exchangers under the tunnel to make sure your coolant is circulating.It is not normal for this sled to overheat.
 

·
Registered
Joined
·
221 Posts
Check your primer as well. After all summer sitting the seal in the primer, or the check valves, may be dried up. This will allow extra fuel to be drawn into the engine, flooding it basiclly. Once you get the rpms up there is enough air flowing in the help burn the fuel off.
 

·
Registered
Joined
·
252 Posts
I worked on my brothers formula mx that would overheat constantly. We tried everything we cold think of and final pulled the head to check the o- rings. One o-ring was split. put in a new ring and ran it for 400 miles with no problem.
 

·
Registered
Joined
·
799 Posts
My 583 Form Dlx was always running hot when I first got it; took it back to the dealer, it was a bad temp gauge. They swapped it out, never had the problem since.

Jacqui.
 

·
Registered
Joined
·
624 Posts
Just a thought here.. If this was your first ride of the season, did you happen to check for any restriction in your exhaust outlet? My buddy had a mouse nest in one of his pipes on his ZRT last year. :0:
 
1 - 15 of 15 Posts
Top