Snowmobile World banner

1 - 20 of 25 Posts

·
Premium Member
Joined
·
575 Posts
NO plugs! :D
I went two seasons..........5200 miles on the same set.
 

·
oldslowsledder
Joined
·
6,491 Posts
Only ever fouled one a year on my Legend, both times same senerio, late in season, mild temps and long cruise. Can't complain about that :D
 

·
Registered
Joined
·
578 Posts
I haven't fouled one since I parked the old 77 Scorpion Whip. That thing took a set or two every ride.

My Formula Plus, Safari and Polaris XLT, never a bad plug. Always clean and like new.

Lucky I guess.

New sled, I hope is a good as these two were.
 

·
Registered
Joined
·
745 Posts
None..I never foul plugs on my olf gem!...I just through a new set of BR9EYA in it every year and put the old ones on the spare plug holder and away we go!
 

·
Registered
Joined
·
568 Posts
The BR9ES were fine but with the Iridiums, they seem to work better at the end of the year. Other than that, I never change them during season.
 

·
Registered
Joined
·
539 Posts
I install new plugs at the start of the season and that's it....good to go all year
 

·
Senior Member
Joined
·
10,054 Posts
I used to foul plugs on the ol zrt about every 200 mile. Now with the firecat, I run an entire season without fouling. I change them after the first ride of the new season since I fog my motors, and then dont worry about changing them until next year. ITS GREAT!!!
 

·
Registered
Joined
·
75 Posts
I change them after the first ride of the new season since I fog my motors, and then dont worry about changing them until next year. ITS GREAT!!!
[/b]
Likewise, after the first run of a season I put in a fresh set and am good for the season.
Two reasons, the fall fogging and the first run of a season I also run a fuel/oil mix just to verify the oil pump is still functioning.
 

·
Registered
Joined
·
411 Posts
Never fouled with the SkiDoo, we'll see how the Yammi does this year. Had her out last weekend for a little romp, and will put the new plugs in tonight. (the old ones looked fine after riding last weekend, but are last years - and we don't want last years model in there with the way the "new plugs" look, gotta be fashionable you know :lmao: :lmao: :lmao: )
 

·
Registered
Joined
·
11,658 Posts
the plugs get changed when i get around to it. i'm using the set that i fogged my sled with but i'll change then in the next couple days.
 

·
Registered
Joined
·
286 Posts
None...ZR900 efi
 

·
Registered
Joined
·
1,167 Posts
I'VE FOWLED 3 SO FAR THIS YEAR ON MY 01 PANTERA 580=EFI.
IT ONLY HAPPENS DURING STARTING.
WHAT'S UP WITH THAT CAT??? :lookaround:
 
1 - 20 of 25 Posts
Top