Snowmobile World banner

1 - 12 of 12 Posts

·
Registered
Joined
·
319 Posts
Discussion Starter #1
man its been a long time since i was on this board why is it so slow.
it is not my computer or internet connection iam on high speed dsl.
it takes so long to change pages or just do anything.
 

·
Registered
Joined
·
38 Posts
Originally posted by mach1@Nov 20 2004, 06:54 PM
man its been a long time since i was on this board why is it so slow.
it is not my computer or internet connection iam on high speed dsl.
it takes so long to change pages or just do anything.
[snapback]365673[/snapback]​

Man...........I thought it was only me! This is painfully slow! I've been noticing but just thought it was my cable server:(............Great site but tooo slow.
 

·
Registered
Joined
·
2,422 Posts
Agreed! Something HAS to change or people will just get fed-up and leave :bash:
 

·
Banned
Joined
·
5,166 Posts
There hasn't been a post on these forums in MONTHS saying anything about the site speed. Again, the site is slow RIGHT NOW due to an issue unrelated to this site and is being worked on.

There is not much else I can do. The site is not normally slow, it is just bad right now. That's about all I can say.
 

·
oldslowsledder
Joined
·
6,491 Posts
I have the same complaint, many times over the last couple months I've got frustrated waiting for the site to load then end up waiting to read posts and end up just leaving. There used to be a selection under 'my controls' where you could go to 'skins and languages' and select faster surfing and that really helped, but I can no longer find that. Hope the problems get worked out.
 

·
Registered
Joined
·
3,413 Posts
Was slow earlier today, but seems to be moving along real good now. SWRules
 
1 - 12 of 12 Posts
Top