Snowmobile World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Yes it has been a while and now that we have snow my kids wanted to get the sleds running. Problem is a 94 stx (583)has been sitting a while and primer broke (primer nipple popped off and yes it is a new one) carbs are dry managed to get gas to the bowls. Has spark but still would not start so I put a little gas down the cylinder she fires but won't run. I then put new plugs in and tried again than pulled carbs and the boot to the cylinder is "wet" both sides. The floats/needle moved free. I didn't measure height (still looking for manual). What am I over looking? Thanks
 

·
Registered
Joined
·
9 Posts
Discussion Starter #2
Yes it has been a while and now that we have snow my kids wanted to get the sleds running. Problem is a 94 stx (583)has been sitting a while and primer broke (primer nipple popped off and yes it is a new one) carbs are dry managed to get gas to the bowls. Has spark but still would not start so I put a little gas down the cylinder she fires but won't run. I then put new plugs in and tried again than pulled carbs and the boot to the cylinder is "wet" both sides. The floats/needle moved free. I didn't measure height (still looking for manual). What am I over looking? Thanks[/b]
 

·
Registered
Joined
·
76 Posts
Yes it has been a while and now that we have snow my kids wanted to get the sleds running. Problem is a 94 stx (583)has been sitting a while and primer broke (primer nipple popped off and yes it is a new one) carbs are dry managed to get gas to the bowls. Has spark but still would not start so I put a little gas down the cylinder she fires but won't run. I then put new plugs in and tried again than pulled carbs and the boot to the cylinder is "wet" both sides. The floats/needle moved free. I didn't measure height (still looking for manual). What am I over looking? Thanks[/b]
Almost sounds like you got water in the bottom of the tank, is your fuel filter filling up? I wonder if you put a new primer on if you will be good to go. How was it running when you shut it down last year?

Really sounds like there is NO major problems if it was running good at the end of last season.
 

·
Registered
Joined
·
193 Posts
Yes it has been a while and now that we have snow my kids wanted to get the sleds running. Problem is a 94 stx (583)has been sitting a while and primer broke (primer nipple popped off and yes it is a new one) carbs are dry managed to get gas to the bowls. Has spark but still would not start so I put a little gas down the cylinder she fires but won't run. I then put new plugs in and tried again than pulled carbs and the boot to the cylinder is "wet" both sides. The floats/needle moved free. I didn't measure height (still looking for manual). What am I over looking? Thanks[/b]
I belive if you primer is broke you will suck air, cause it to run lean, and your carbs need to be gone through if you have not yet done that. or you could be just flooding it out. happen to my budy in the first of the year. he was pullin and pullin, for a hour. then we held the throttle wide open and it fired rite up. still go through carbs with cleaner and compressed air. Crash Dummy
 
1 - 4 of 4 Posts
Top