Snowmobile World banner

1 - 3 of 3 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
my 1997 mach z's secondary has never been apart. motor has 3k miles on it, was not maintained well by previous owner, and i have noticed that my backshift is lagging. So I decided to take it apart, but the helix is stuck to the outer shieve's shaft.
I have removed the clip, and even cranked the helix down further on the shaft (with tool) in hoping that it would spring back up after releasing the tool. But it just remained further down on the shaft!
I have been dousing it with wd-40 and tapping on it with a hammer to distribute the wd-40 to no avail. Also heated the shaft with a hot air gun and repeated. Still stuck !

Any suggestions? Thanks To All.

robb
 

·
Registered
Joined
·
118 Posts
If you have the helix pushed down on the shaft and it won't return, use the tool in your toolkit that spreads the sheaves apart. This should push the helix back. Be careful though if you have removed the clip! You may have to work the helix back and forth a couple of times before it will finally come off. Keep using the WD-40 as well. I worked on a buddy's 98 F-Z 670 and had to work it back and forth about six times before it finally came off! The second time I drove the helix deep into the secondary and then used some 600 grit sandpaper to clean the rust off the shaft. Hope this helps.
 

·
Registered
Joined
·
1,859 Posts
they can be a real son of bit*h to get appart. use your hammer and keep pounding  she will come out....lol i know i put a post here last year i couldnt beleive it was stuck and that what they told me and thats what it was.gl
 
1 - 3 of 3 Posts
Top