Snowmobile World banner
1 - 9 of 9 Posts

·
Registered
Joined
·
4,429 Posts
I was in bancroft this afternoon . there were fresh sled tracks on the railway bed and in coe hill on the railbed. The trail looked icy and fast. I could see very few if any open spots on the trail but getting gas is an ashphalt run
 

·
Registered
Joined
·
56 Posts
I was at the Algonquin Lodge from Friday to Tuesday. Thats at Lake St.Peter? I think is the name. We rode from the lodge on Monday to Whitney to Barrys Bay to Pembrook sp? Back to Barrys Bay then back to the lodge. 275 miles the trails north were good. On Tuesday it was raining and in the 40s F.
Unless they received snow since Tuesday I cant imagine that the trails would be very good now.
Hope this helps.
That area was a great place to ride!!
 

·
Registered
Joined
·
807 Posts
Discussion Starter · #6 ·
Well I went up, what a waste, no snow at all, and I went to Birds Creek. To bad I didn't know you were going to the drags. I went, and had no hookup on the glare ice, stuck around for awhile, but still hadn't started by 1pm so we split. What kind of MPH were some running?
 

·
Registered
Joined
·
3,208 Posts
I tried to get to the races but sled engine temps went really high and conditions were crap 4 people in my group crashed on a hill when then spun backwards.  So i just parked the sled.  I dont think the trails should have been open.  And to make it worse its starts snowing on saturday night only to turn into the hardest rainstorm i ever saw.  Then today as im leaving and have the sled on my truck it starts to snow.

Mother nature is the  
go pick on tree huggers.
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top