Snowmobile World banner

1 - 4 of 4 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I am working on a 98 zr600 efi. This person brought it to me saying it fouls out plugs a lot. I asked him how often. He said it would foul out on the trail at a steady speed, he would put in a new set of plugs and ride it for 3-4 miles then plugs would be wet. Tonight i looked everything over. I checked all the elecricals and tested them with my ohm meter, they were all in spec. Both injectors tested ok. Compression was even at 135psi. I checked the throttle postition sensor setting which was ok. One thing i did find odd was the fuel hose going to the fuel pressure regulator was sort of pinched inbetween the steering stem and the airbox. Looks as it was routed in a odd way, that couldnt be factory now could it? I dont have a manual for this sled but i did call a dealer to get all the electrical component specs. Does anyone know the correct routing for these fuel lines? WHat i ended up doing just for the time being was take that pinch out of the hose then put in a new set of plugs and ran it. It ran pretty good. I ran her for a while then took her around the field a couple times. Checked the plugs and they were perfect. I am wondering if that pinched hose made things go rich? Anyone haqve any comments or suggestions please chime in.
 

·
Registered
Joined
·
97 Posts
My brother has one of those sleds he bought new, out of the box it was junk for fuel consumption. He bought a new pipe and chip from Black Magic and the sled came to life, fuel consumption dropped, 14-15 mile per gallon now. Save you nickels and dimes and invest in the Black Magic parts, you will love the results.


The sled is 300 mile away so I find it a little hard to take a picture of the fuel line for you.
 
1 - 4 of 4 Posts
Top