Snowmobile World banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2001 ZR600 EFI with Powervalves. The throttle sticks of hisitates when i want to take off. its not really a bog, but a jerk. this would be taking off from a dead stop or letting off the throttle at 25mph and trying to accelerate.

I have my daughter riding in front of me and our helmets hit every time we accelerate after going around a bend of up a hill.

So i took it out on my own and when i gun it, it move, but still has hesitation and a pretty good jerk.

this is the first time i've had the sled out seeing i bought them in Oct. I've been through enough with a 440 carb...i just dont want to worry about it and would like to just ride.
 

·
Premium Member
Joined
·
709 Posts
I don't really understand what the problem is. It sounds like, if I'm reading this right, that maybe the idle is a little low and it takes time to wind up and then the engagement is hitting hard? There should be a pretty good jerk from that engine when it engages the belt unless you are really easy on the throttle.
 

·
Registered
Joined
·
30 Posts
I don't really understand what the problem is. It sounds like, if I'm reading this right, that maybe the idle is a little low and it takes time to wind up and then the engagement is hitting hard? There should be a pretty good jerk from that engine when it engages the belt unless you are really easy on the throttle.[/b]
FWIW - I have a ZL 500 EFI (no power valves) and I guess I can't say I have that problem, but I also own 3 polarii and had a Ski-Doo and a ZL 440. I must admit, the Cats do seem to engage harder than the others I've owned.

So, maybe there is no problem or maybe the power valves are a little sticky? Others here have way more knowledge on the exhaust valves and I'm sure they'll weigh in if they think there is a problem.

Boegey
 

·
Registered
Joined
·
204 Posts
Power valves open at 7200 and close at 6900....dons't sound like that's your problem.

When you say jerk, it's on take off, or once your moveing. There is a chance it has had a clutch kit installed...it would seem a little jerky if it did.

What RPM is it engaugeing at .....should be about 3300-3500 if it's stock.

Theres also a chance that the throtle cut off safty switch is not working right....will feel like the key is being turned of and on....this is usaly when letting off of just starting to accdelart. COMMON problem with these sled's.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
correct, it engages around 3500-4000. I feather the throttle, but it still jolts on me. things i will try tonight. Change the belt. seemed a little lose. just to see. then i'll do the safety switch thing. really starting to get to me...

But i can understand how it may be something stock. my wifes 440 is how i would like i twhen i have the kids along. but when i am alone...i dont mind.
 

·
Registered
Joined
·
204 Posts
A jerk isn't stock. I have a 03 Zl 600 Efi and mine is smoth from take off to WOT. Only kinda of jolt is if I'm spinning my track on it hooks up.

GOOD LUCK.
 

·
Registered
Joined
·
430 Posts
Ok I am guessing that when you apply throttle there is a dead spot like nothing happens for a moment then the sled kicks in.Your sled is EFI so check the box for codes (there will be a blinking light that corresponds to any number of sensor issues etc.)
Another super common issue is the little washers in the throttle. These are part of the carb or throttle body safety switch system. It also wouldn’t hurt to check out the kill switch because they sometimes can be problematic.

Does the sled backfire occasionally when coming out of a corner or when you’re on and off the throttle hard?
If so, that’s either a faulty kill switch and/or throttle switch assembly.

The washers I'm talking about are number 13/14 on the pdf-
 

Attachments

·
Registered
Joined
·
211 Posts
Might be a throttle position sensor. My brother's 05 F6 Efi is suffering from the same problem.

It's in the shop 'cause we couldn't figure it out.... but the sensor is what the mech said it probably is.
 
1 - 8 of 8 Posts
Top